Occassional and Periodic Slowness
Incident Report for Trusted
Resolved
This incident has been resolved.
Posted Nov 20, 2022 - 19:06 UTC
Identified
The application is being overloaded occasionally by an external service on a periodic basis. You may experience short periods of slowness / unresponsiveness on a regular basis until this issue is resolved with the external service.
Posted Nov 20, 2022 - 15:45 UTC
This incident affected: Marketplace (ManageApp).