Partial outage

Incident Report for Trusted

Resolved

This incident has been resolved.
Posted Feb 14, 2023 - 18:35 UTC

Monitoring

A fix is now in place and we are monitoring the results.
Posted Feb 14, 2023 - 18:30 UTC

Identified

Issues with Timesheets on the mobile app
Posted Feb 14, 2023 - 18:18 UTC
This incident affected: Marketplace (Clinicians Web).